SCCM 2007 R2 und der AppV-Client

Gerade eben wollte ich auf meinem Server 2008 inkl. SCCM 2007 R2 (RC) die Integration von AppV (MAV, Microsoft Application Virtualization, SoftGrid oder wie auch immer man es nennen mag) testen.

Also schnell die RC-Version von R2 (build 6335) und Application Virtualization (4.5.0.1308) installiert, hier und da etwas konfiguriert (wie schon bei einer anderen SCCM-Installation, die allerdings auf einem Server 2003 lief) und siehe da … es geht nicht!

Folgende Fehlermeldung kam bei der Ausführung des virtuellen Packages auf dem Client (in diesem Fall dem Siteserver selbst):

Failed to open the WMI namespace [root\microsoft\softgrid\client].  Error (0x8004100e)   VAppQuery
CVAppQuery::PackageInUse() failed for virtual app package [{1C84B292-F491-4BFF-9D1A-DC519312B2B8}]. (0x8004100e)  VAppQuery
CVAppRegistration::ExecuteAdd failed for the virtual application package. (0x8004100e)       VAppRegistration

Auffällig ist, dass der Client versuchte, den WMI-Namespace "root\microsoft\softgrid\client" zu öffnen. Seltsam. Was sucht denn das "Softgrid" in dem Namespace? Diesen gibt’s tatsächlich nicht in der WMI. "root\microsoft\appvirt\client" hingegen schon. Komisch, komisch … mit exakt den gleichen Sourcen lief das doch auf der anderen SCCM-Site einwandfrei.

Lange Rede, kurzer Sinn. Der SCCM-Client war schuld, weil nicht aktuell. Der Fehler trat mit Version "4.00.6086.1000" auf; eine Aktualisierung auf "4.00.6221.1000" behob das Problem.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.