No response from Windows Deployment Services server

Kürzlich bin ich über ein interessantes Problem gestolpert. Clients war es nicht möglich, einen PXE-Boot durchzuführen.

Clientseitig sah dies so aus:

„Downloaded WDSNBP
Architecture: x64
WDSNBP started using DHCP Referral.
Contacting Server: X.X.X.X
No response from Windows Deployment Services server.
Launching pxeboot.com
TFTP download failed.“

Im smspxe.log war die Anfrage des Clients zu finden. Also den Netzwerk-Monitor angeworfen und den Traffic zwischen Client und PXE-ServicePoint mitgeschnitten:

Auffallend sind hier zwei Dinge:
(1) eine lange Zeitdauer (7s) zwischen Antwort vom Server (Frame 1688) und Anfrage vom Client (1818, gelb markiert).

(2) der Client fordert die Datei „pxeboot.com“ an, die es aber leider nicht im RemoteInstall-Verzeichnis gibt.

Ein Vergleich zu einem funktionierenden PXE-Boot zeigt folgendes:

Hier fordert der Client „smsboot\x64\pxeboot.com“ an. Diese Datei ist natürlich im RemoteInstall-Verzeichnis vorhanden (im Gegensatz zu „\pxeboot.com“).

An dieser Stelle war ich erst einmal ratlos. Lange Rede – kurzer Sinn: die Zusammenarbeit mit einem LAN-Kollegen ergab, dass „DHCP Snooping“ aktiviert war und somit die DHCP-Antwort (Frame 1688) niemals am Client angekommen ist. Weitere Informationen zu „DHCP snooping“ auf der Site von Cisco: http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.1/12ew/configuration/guide/dhcp.pdf.

Ein Gedanke zu „No response from Windows Deployment Services server

  1. Pingback: 2K8R2 - SCCM 2007 R2 OS Deployment WDS Konfig - Seite 2 - MCSEboard.de MCSE Forum

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.